<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>Larry Storch, Zany Cpl. Agarn on TV&#8217;s &#8216;F Troop,&#8217; Dies at 99 &#8211; NBC4 Washington</title>
<link rel="preload" href="https://www.nbcwashington.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Black.woff2" as="font" crossorigin />
<link rel="preload" href="https://www.nbcwashington.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Bold.woff2" as="font" crossorigin />
<link rel="preload" href="https://www.nbcwashington.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Medium.woff2" as="font" crossorigin />
<link rel="preload" href="https://www.nbcwashington.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Light.woff2" as="font" crossorigin />
<link rel="preload" href="https://www.nbcwashington.com/wp-content/themes/nbc-station/client/build/media/Roboto-Flex.woff2" as="font" crossorigin />
<link rel='dns-prefetch' href='//z.moatads.com' />
<link rel='dns-prefetch' href='//assets.adobedtm.com' />
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NBC4 Washington &raquo; Feed" href="https://www.nbcwashington.com/?rss=y" />
<style class="wp-asset-manager nbc-common-css" type="text/css">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</style><style class="wp-asset-manager nbc-global-css" type="text/css">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</style><link rel='stylesheet' id='all-css-0' href='https://www.nbcwashington.com/_static/??-eJydzEEOwiAQheELWei00wEXxoUX8AoMA5FIwQiN11djvEDX73+ffj0GX0sPpet+C2tourAfWnc91aJ9Tt+Ft5RF+9a0e/bkc1AmRFpmIYqEMWK0I4taU1Gf6KD3oZffRaEYHGmBKDhbJ96C4d025+rvTZEVnkwQRrDgzGLRjrvNtbZ+rY8tu6fybJkAkI5uIgwQJjF/+LyegBYzjwiEb10EfcI=' type='text/css' media='all' />
<script id='ad-layers-dfp-js-extra'>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script src='https://www.nbcwashington.com/wp-content/plugins/ad-layers-nbc/js/ad-layers-dfp.js?ver=0.0.9' id='ad-layers-dfp-js'></script>
<script id='ad-layers-js-extra'>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script src='https://www.nbcwashington.com/wp-content/plugins/ad-layers-nbc/js/ad-layers.js?ver=0.0.9' id='ad-layers-js'></script>
<link rel="https://api.w.org/" href="https://www.nbcwashington.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nbcwashington.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nbcwashington.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.9" />
<link rel="canonical" href="https://apnews.com/c476d7b63a3376ffe739d276224e3101" />
<link rel="alternate" type="application/json+oembed" href="https://www.nbcwashington.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcwashington.com%2Fentertainment%2Fentertainment-news%2Flarry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99%2F3096337%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nbcwashington.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcwashington.com%2Fentertainment%2Fentertainment-news%2Flarry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99%2F3096337%2F&#038;format=xml" />
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
		<style type='text/css'>img#wpstats{display:none}</style><script>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</script><style type="text/css">
	.hero-background:empty.hero-loaded { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcwashington.com/2019/09/OTT-Washington-DC.png?resize=800%2C231&quality=85&strip=all'); }
</style>
<script>
	window.addEventListener('DOMContentLoaded', function(){
		var hero = document.querySelector('.hero-background');
		hero.classList.add('hero-loaded');
	});
</script>
<meta property="og:site_name" content="NBC4 Washington" /><meta name="google-site-verification" content="V-1N4cprg5uHAuJD5dPgh6lkKjRpqioG6aoxsXIEZfc" /><meta property="fb:app_id" content="168641655540" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@nbcwashington" /><meta name="twitter:creator" content="@nbcwashington" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="article:publisher" content="http://www.facebook.com/nbcwashington" /><meta name="description" content="An actor best known for the 1960s TV Western spoof “F Troop” has died. Larry Storch, who played Corporal Agarn, died early Friday. His manager says the..." /><meta property="og:description" content="An actor best known for the 1960s TV Western spoof “F Troop” has died. Larry Storch, who played Corporal Agarn, died early Friday. His manager says the actor died of natural causes. “F Troop” lasted only two seasons on ABC, from 1965 to 1967, but it became a cult favorite in reruns. While “F Troop” brought him lasting fame, Storch appeared in scores of films and TV shows before and after the series. He also enjoyed a long career in theater and as a comic at resorts in New York State’s Catskill Mountains area. Larry Storch was 99." /><meta name="twitter:description" content="An actor best known for the 1960s TV Western spoof “F Troop” has died. Larry Storch, who played Corporal Agarn, died early Friday. His manager says the actor died of natural causes. “F Troop” lasted only two seasons on ABC, from 1965 to 1967, but it became a cult favorite in reruns. While “F Troop” brought him lasting fame, Storch appeared in scores of films and TV shows before and after the series. He also enjoyed a long career in theater and as a comic at resorts in New York State’s Catskill Mountains area. Larry Storch was 99." /><meta property="og:title" content="Larry Storch, Zany Cpl. Agarn on TV&#039;s ‘F Troop,&#039; Dies at 99" /><meta name="twitter:title" content="Larry Storch, Zany Cpl. Agarn on TV&#039;s ‘F Troop,&#039; Dies at 99" /><meta name="keywords" content="larry storch" /><meta property="og:url" content="https://www.nbcwashington.com/entertainment/entertainment-news/larry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99/3096337/" /><meta name="twitter:url" content="https://www.nbcwashington.com/entertainment/entertainment-news/larry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99/3096337/" /><meta name="sailthru.title" content="Larry Storch, Zany Cpl. Agarn on TV&#039;s ‘F Troop,&#039; Dies at 99" /><meta name="sailthru.description" content="An actor best known for the 1960s TV Western spoof “F Troop” has died. Larry Storch, who played Corporal Agarn, died early Friday. His manager says the..." /><meta name="sailthru.tags" content="larry storch" /><meta name="sailthru.tags" content="larry storch" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2022-07-08T14:31:28+00:00" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image" content="https://media.nbcwashington.com/2022/07/larry_storch.png?resize=1200%2C675&#038;quality=85&#038;strip=all" /><meta name="twitter:image" content="https://media.nbcwashington.com/2022/07/larry_storch.png?resize=1200%2C675&#038;quality=85&#038;strip=all" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.nbcwashington.com\/entertainment\/entertainment-news\/larry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99\/3096337\/","headline":"Larry Storch, Zany Cpl. Agarn on TV's \u2018F Troop,' Dies at 99","datePublished":"2022-07-08T14:31:28","dateModified":"2022-07-08T14:31:28","description":"An actor best known for the 1960s TV Western spoof \u201cF Troop\u201d has died. Larry Storch, who played Corporal Agarn, died early Friday. His manager says the\u2026","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"larry storch","publisher":{"@type":"Organization","name":"NBC4 Washington","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/media.nbcwashington.com\/wp-content\/uploads\/2022\/05\/amp_square_wrc.png","width":160}},"image":{"@type":"ImageObject","height":675,"url":"https:\/\/media.nbcwashington.com\/2022\/07\/larry_storch.png?resize=1200%2C675&quality=85&strip=all","width":1200},"author":{"@type":"Person","name":"Lynn Elber"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">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</script>
			<link rel="amphtml" href="https://www.nbcwashington.com/entertainment/entertainment-news/larry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99/3096337/?amp"><link rel="icon" href="https://media.nbcwashington.com/2019/09/cropped-NBC_Washington.png?fit=32%2C32&#038;quality=85&#038;strip=all" sizes="32x32" />
<link rel="icon" href="https://media.nbcwashington.com/2019/09/cropped-NBC_Washington.png?fit=192%2C192&#038;quality=85&#038;strip=all" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.nbcwashington.com/2019/09/cropped-NBC_Washington.png?fit=180%2C180&#038;quality=85&#038;strip=all" />
<meta name="msapplication-TileImage" content="https://media.nbcwashington.com/2019/09/cropped-NBC_Washington.png?fit=270%2C270&#038;quality=85&#038;strip=all" />
</head>

<body class="post-template-default single single-post postid-3096337 single-format-standard station-nbc wrc has-featured-image short-hero">
	<div id="leaderboard" class="leaderboard-ad">
		<div id="div-gpt-ad-topbanner_" class=" gpt-topbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbanner_', format: 'topbanner', targeting: {"slot":"topbanner","pos":"topbanner"} });
			</script><div id="div-gpt-ad-mobiletopbanner_" class=" gpt-mobiletopbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobiletopbanner_', format: 'mobiletopbanner', targeting: {"slot":"mobiletopbanner","pos":"mobiletopbanner"} });
			</script>	</div>
	<div id="page" class="site" data-component="wrapper">
	
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
		<div class="site-header__primary">
		<div class="site-header__wrap">
							<div class="site-header__logo">
					<a href="https://www.nbcwashington.com/">
						<img src="https://media.nbcwashington.com/2019/09/DC_On_Dark@3x-1.png?fit=558%2C120&#038;quality=85&#038;strip=all&#038;w=186&#038;h=40" srcset="https://media.nbcwashington.com/2019/09/DC_On_Dark@3x-1.png?fit=558%2C120&amp;quality=85&amp;strip=all&amp;w=186&amp;h=40 1x, https://media.nbcwashington.com/2019/09/DC_On_Dark@3x-1.png?fit=558%2C120&amp;quality=85&amp;strip=all&amp;w=372&amp;h=80 2x, https://media.nbcwashington.com/2019/09/DC_On_Dark@3x-1.png?fit=558%2C120&amp;quality=85&amp;strip=all&amp;w=558&amp;h=120 3x" alt="NBC4 Washington" height="40" width="186" />					</a>
				</div>
						<div class="site-header__nav-search">
				<div class="site-header__nav-main">
					<button class="site-header__nav-main-toggle">
						<span class="site-header__nav-main-toggle-text">Main Navigation</span>
					</button>
				</div>
				<div class="site-header__search" data-component="headerSearch">
					<button class="site-header__search-toggle">
						<span class="site-header__search-toggle-text">Search</span>
					</button>
					<div class="site-header__search-form">
						
<form class="search-form" role="search" method="get" action="https://www.nbcwashington.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
				</div>
			</div>
			<div class="site-header__animated-section">
				<nav class="site-header__nav-sections">
					<div class="menu-primary-menu-container"><nav id="primary-menu" class="menu"><a data-lid="Local" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/local/">Local</a></li>
<a data-lid="Coronavirus" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/coronavirus/">Coronavirus</a></li>
<a data-lid="U.S. &amp; World" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/national-international/">U.S. &amp; World</a></li>
<a data-lid="Weather" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="https://www.nbcwashington.com/category/weather/">Weather</a></li>
<a data-lid="Sports" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/sports/">Sports</a></li>
<a data-lid="Investigations" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/investigations/">Investigations</a></li>
<a data-lid="The Scene" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/entertainment/the-scene/">The Scene</a></li>
<a data-lid="Newsletters" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="https://www.nbcwashington.com/newsletters/">Newsletters</a></li>
</nav></div>				</nav>
				<div class="site-header__weather-tv">
					<div
						class="site-header__local-weather"
						data-react-component="NBCWeather"
						data-view="conditions"
					>
					</div>
										<a class="site-header__live-tv" href="https://www.nbcwashington.com/live">Live TV</a>
									</div>
				<button class="site-header__mobile-share-toggle">
					<span class="text-share">Share</span>
					<span class="text-close">Close</span>
				</button>
			</div>
		</div> <!-- site-header__wrap -->
	</div> <!-- site-header__primary -->
	<div class="site-header__secondary">
		<div class="site-header__wrap">
							<div class="site-header__trending">
					<span class="site-header__trending-label">Trending</span>
											<nav class="site-header__trending-nav">
												<a data-lid="New DC Wegmans" data-lpos="trending-stories-module" href="https://www.nbcwashington.com/news/local/a-first-look-inside-the-new-dc-wegmans-location/3094768/" class="site-header__trending-nav-item">New DC Wegmans</a>
					<a data-lid="The Weekend Scene" data-lpos="trending-stories-module" href="https://www.nbcwashington.com/entertainment/the-scene/the-weekend-scene-15-things-to-do-in-the-dc-area-to-shake-up-summer/3094994/" class="site-header__trending-nav-item">The Weekend Scene</a>
					<a data-lid="Outdoor Movies" data-lpos="trending-stories-module" href="https://www.nbcwashington.com/entertainment/the-scene/outdoor-movies-return-to-dc-maryland-virginia-for-summer-2022/3042707/" class="site-header__trending-nav-item">Outdoor Movies</a>
					<a data-lid="Storm Team4 Forecast" data-lpos="trending-stories-module" href="https://www.nbcwashington.com/weather/weather-stories/current_forecast_dc/91018/" class="site-header__trending-nav-item">Storm Team4 Forecast</a>
					<a data-lid="Brittney Griner" data-lpos="trending-stories-module" href="https://www.nbcwashington.com/tag/brittney-griner/" class="site-header__trending-nav-item">Brittney Griner</a>
					<a data-lid="75 Years of NBC4" data-lpos="trending-stories-module" href="https://www.nbcwashington.com/tag/75-years-of-nbc4/" class="site-header__trending-nav-item">75 Years of NBC4</a>
					<a data-lid="Payment Safety" data-lpos="trending-stories-module" href="https://www.consumerreports.org/digital-payments/how-to-protect-peer-to-peer-payments-a1478958356/" class="site-header__trending-nav-item">Payment Safety</a>
					<a data-lid="Watch 24/7 on Roku" data-lpos="trending-stories-module" href="https://www.nbcwashington.com/on-nbc4/about-us/nbc4-washington-news-watch-local-news-on-roku-anytime/3087767/?_osource=mk_npd_nbc_dc_ot_genroku" class="site-header__trending-nav-item">Watch 24/7 on Roku</a>
		
							</nav>
										<div class="site-header__trending-toggle">
						<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
					</div>
				</div>

				
<div class="site-header__alerts">
	<div
		class="site-header__weather "
		data-react-component="NBCWeather"
		data-view="alerts"
		data-alert-singular="Weather Alert"
		data-alert-plural="Weather Alerts"
		data-zip-code="20001">
	</div>
	</div> <!-- site-header__wrap -->
					</div> <!-- site-header__secondary -->
	</div>
</header>
	<div id="content" class="site-content " data-component="formsContainer">
		<div id="primary" class="content-area">
			<main id="main" class="site-main">
				<article id="post-3096337" data-component="article">

	<div
			id="template-hero"
		class="template-hero "
		data-component="templateHero"
	>
			<div class="hero-background"></div>
	
	
	
					
	
	
	
	
	
	
	</div>
		<div class="section-content--header below-hero">
		<div class="article-eyebrow__container">
	<div class="article-eyebrow__wrap">
									<a class="article-eyebrow" href="https://www.nbcwashington.com/tag/larry-storch/">larry storch</a>						</div>
	</div>
<div class="article-header--wrap ">
	<h1 class="article-headline">
		Larry Storch, Zany Cpl. Agarn on TV's ‘F Troop,' Dies at 99	</h1>
			<h2 class="article-subtitle">
			Although “F Troop” lasted only two seasons on ABC, from 1965 to 1967, it became a cult favorite in reruns		</h2>
				
<div class="article-meta" data-component="articleMeta">
	<h4 class="article-byline">
					By Lynn Elber							<span class="meta-dot">&bull;</span>
					
									<span class="time-wrap">
					<time class="entry-date published" datetime="2022-07-08T18:31:28-04:00">Published 1 hour ago</time>				</span>
						</h4>
	<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcwashington.com%2Fentertainment%2Fentertainment-news%2Flarry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99%2F3096337%2F&#038;Larry%20Storch%2C%20Zany%20Cpl.%20Agarn%20on%20TV%27s%20%E2%80%98F%20Troop%2C%27%20Dies%20at%2099?_osource=db_npd_nbc_wrc_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Larry%20Storch%2C%20Zany%20Cpl.%20Agarn%20on%20TV%27s%20%E2%80%98F%20Troop%2C%27%20Dies%20at%2099&#038;url=https%3A%2F%2Fwww.nbcwashington.com%2Fentertainment%2Fentertainment-news%2Flarry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99%2F3096337%2F?_osource=db_npd_nbc_wrc_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Larry%20Storch%2C%20Zany%20Cpl.%20Agarn%20on%20TV%27s%20%E2%80%98F%20Troop%2C%27%20Dies%20at%2099%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcwashington.com%2Fentertainment%2Fentertainment-news%2Flarry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99%2F3096337%2F?_osource=db_npd_nbc_wrc_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
	</div>
</div>
		</div>
	</div>
		<div class="section-content--full below-hero">
		<div class="section-content--primary">
			<div class="article-content--wrap">
				<figure class="article-featured-media">
	<div class="image-container">
		<img
			srcset="https://media.nbcwashington.com/2022/07/larry_storch.png?resize=320%2C180&amp;quality=85&amp;strip=all 320w, https://media.nbcwashington.com/2022/07/larry_storch.png?resize=400%2C225&amp;quality=85&amp;strip=all 400w, https://media.nbcwashington.com/2022/07/larry_storch.png?resize=500%2C281&amp;quality=85&amp;strip=all 500w, https://media.nbcwashington.com/2022/07/larry_storch.png?resize=600%2C338&amp;quality=85&amp;strip=all 600w, https://media.nbcwashington.com/2022/07/larry_storch.png?resize=850%2C478&amp;quality=85&amp;strip=all 850w, https://media.nbcwashington.com/2022/07/larry_storch.png?resize=1200%2C675&amp;quality=85&amp;strip=all 1200w, "
			sizes="(max-width: 768px) 100vw, (max-width: 1200px) calc(100vw - 350px), 850px"
			src="https://media.nbcwashington.com/2022/07/larry_storch.png?resize=320%2C180&#038;quality=85&#038;strip=all"
			alt=""
		/>
	</div>
			<figcaption>
							<cite>AP Photo/David F. Smith</cite>
			
												<div
						class="caption"
						data-react-component="NBCTruncate"
						data-maxlines="2"
						data-maxlinesmobile="4"
						data-readmore="Read more"
						data-text="In this Dec. 2, 1966 photo, actor Larry Storch, one of the co-stars of “F Troop,” poses during the filming of an episode at the Warner Brothers studio in Los Angeles."
						data-ellipsis="false">
					</div>
									</figcaption>
	</figure>
									<div class="article-content rich-text">
									
					
<p>Larry Storch, the rubber-faced comic whose long career in theater, movies and television was capped by his “F Troop” role as zany Cpl. Agarn in the 1960s spoof of Western frontier TV shows, died Friday. Storch was 99.</p>

<p>Storch died of natural causes early Friday in his New York City apartment, according to his manager, Matt Beckoff.</p>

<p>Although “F Troop” lasted only two seasons on ABC, from 1965 to 1967, it became a cult favorite in reruns. Its devoted fans could recite almost all of the adventures of the incredibly incompetent soldiers of Fort Courage and the members of the nearby Native American tribe who only pretended to be at war with them.</p>

<p>As Agarn, Storch was the wild-eyed partner and protege of Forrest Tucker’s wily Sgt. O’Rourke, who often schemed with Frank DeKova’s Chief Wild Eagle to fleece unsuspecting visitors. Ken Berry’s Capt. Parmenter was Fort Courage’s clueless commander.</p>
<div class="mobile-app-promotion">
	
<div class="wp-block-nbc-localized-block">
<blockquote class="featured-text">
	Stay informed about local news and weather in the D.C. area. Get the NBC4 Washington <em>app for</em><strong><em> </em></strong><a href="https://apps.apple.com/app/id331810768">iOS</a> <strong><em><em>or</em></em></strong> <a href="https://play.google.com/store/apps/details?id=com.nbcuni.nbcots.nbcwashington.android&amp;&amp;">Android</a> and pick your alerts. </blockquote>
</div>
</div>

<p>While “F Troop” brought him lasting fame, Storch appeared in scores of films and TV shows both before and after the show. He also enjoyed a long career in theater and as a comic at resorts in New York State’s Catskill Mountains area. </p>

<p>He never regretted being best known for the series, his manager said.</p>

<p>“He embraced it. He loved being Agarn” and relished working with his co-stars, said Beckoff. Storch was the “kindest, sweetest person," who always had time for autograph-seekers and was generous to people in need, he said.</p>
<div class="recirc-module">
	<h3 class="recirc__heading">Entertainment News</h3>
	<p class="recirc__subheading"></p>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Prince Harry Wins First Stage in Suit Against UK Tabloid Over ‘Defamatory&#039; Article" href="https://www.nbcwashington.com/entertainment/entertainment-news/prince-harry-wins-first-stage-in-suit-against-uk-tabloid-over-defamatory-article/3096329/">
														<img alt="" class="post__image" srcset="https://media.nbcwashington.com/2022/06/GettyImages-1400891447.jpg?quality=85&amp;strip=all&amp;fit=3594%2C2563&amp;w=130&amp;h=73&amp;crop=1 130w, https://media.nbcwashington.com/2022/06/GettyImages-1400891447.jpg?quality=85&amp;strip=all&amp;fit=3594%2C2563&amp;w=170&amp;h=96&amp;crop=1 170w, https://media.nbcwashington.com/2022/06/GettyImages-1400891447.jpg?quality=85&amp;strip=all&amp;fit=3594%2C2563&amp;w=210&amp;h=118&amp;crop=1 210w, https://media.nbcwashington.com/2022/06/GettyImages-1400891447.jpg?quality=85&amp;strip=all&amp;fit=3594%2C2563&amp;w=250&amp;h=141&amp;crop=1 250w, https://media.nbcwashington.com/2022/06/GettyImages-1400891447.jpg?quality=85&amp;strip=all&amp;fit=3594%2C2563&amp;w=290&amp;h=163&amp;crop=1 290w, https://media.nbcwashington.com/2022/06/GettyImages-1400891447.jpg?quality=85&amp;strip=all&amp;fit=3594%2C2563&amp;w=330&amp;h=186&amp;crop=1 330w" src="https://media.nbcwashington.com/2022/06/GettyImages-1400891447.jpg?quality=85&#038;strip=all" loading="lazy" sizes="(min-width: 768px) 166px, 124px" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="British Royal Family" class="post__tag" href="https://www.nbcwashington.com/tag/british-royal-family/">British Royal Family</a>
																			<span class="post__date post__date--has-category">
								2 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Prince Harry Wins First Stage in Suit Against UK Tabloid Over ‘Defamatory&#039; Article" class="post__title--link" href="https://www.nbcwashington.com/entertainment/entertainment-news/prince-harry-wins-first-stage-in-suit-against-uk-tabloid-over-defamatory-article/3096329/">
								Prince Harry Wins First Stage in Suit Against UK Tabloid Over ‘Defamatory&#039; Article							</a>
						</h3>
									</div>
			</div>
		</div>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Macy Gray Addresses Controversial Comments About Gender Identity: ‘This Was a Huge Learning Experience&#039;" href="https://www.nbcwashington.com/entertainment/entertainment-news/macy-gray-addresses-controversial-comments-about-gender-identity-this-was-a-huge-learning-experience/3095926/">
														<img alt="" class="post__image" srcset="https://media.nbcwashington.com/2022/07/GettyImages-1241765057.jpg?quality=85&amp;strip=all&amp;fit=3000%2C1999&amp;w=130&amp;h=73&amp;crop=1 130w, https://media.nbcwashington.com/2022/07/GettyImages-1241765057.jpg?quality=85&amp;strip=all&amp;fit=3000%2C1999&amp;w=170&amp;h=96&amp;crop=1 170w, https://media.nbcwashington.com/2022/07/GettyImages-1241765057.jpg?quality=85&amp;strip=all&amp;fit=3000%2C1999&amp;w=210&amp;h=118&amp;crop=1 210w, https://media.nbcwashington.com/2022/07/GettyImages-1241765057.jpg?quality=85&amp;strip=all&amp;fit=3000%2C1999&amp;w=250&amp;h=141&amp;crop=1 250w, https://media.nbcwashington.com/2022/07/GettyImages-1241765057.jpg?quality=85&amp;strip=all&amp;fit=3000%2C1999&amp;w=290&amp;h=163&amp;crop=1 290w, https://media.nbcwashington.com/2022/07/GettyImages-1241765057.jpg?quality=85&amp;strip=all&amp;fit=3000%2C1999&amp;w=330&amp;h=186&amp;crop=1 330w" src="https://media.nbcwashington.com/2022/07/GettyImages-1241765057.jpg?quality=85&#038;strip=all" loading="lazy" sizes="(min-width: 768px) 166px, 124px" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="Macy Gray" class="post__tag" href="https://www.nbcwashington.com/tag/macy-gray/">Macy Gray</a>
																			<span class="post__date post__date--has-category">
								11 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Macy Gray Addresses Controversial Comments About Gender Identity: ‘This Was a Huge Learning Experience&#039;" class="post__title--link" href="https://www.nbcwashington.com/entertainment/entertainment-news/macy-gray-addresses-controversial-comments-about-gender-identity-this-was-a-huge-learning-experience/3095926/">
								Macy Gray Addresses Controversial Comments About Gender Identity: ‘This Was a Huge Learning Experience&#039;							</a>
						</h3>
									</div>
			</div>
		</div>
	</div>

<p>Storch's credits included “Funny Valentine,” “Sweet 16,” “Sex and the Single Girl,” “S.O.B.,” “Airport,” “Treasure Island” and “Oliver Twist.” On TV, he guest-starred on such shows as “Married... With Children,” “Archie Bunker’s Place,” “Trapper John, M.D.,” “Fantasy Island,” CHiPS,” “The Love Boat,” “Get Smart,” “Love American Style,” “Gilligan’s Island” and “Car 54 Where Are You?”</p>

<p>His many theater appearances ranged from a brutal detective in a 1983 Broadway revival of “Porgy and Bess” to Chief Sitting Bull in the 2000 revival of “Annie Get Your Gun” with Reba McEntire.</p>

<p>Storch said in a 1998 interview that he was surprised to be considered for an Army comedy such as “F Troop,” with it being well known that he served in the Navy during World War II. “All I knew about horses was that they give milk and can bite from both ends,” he quipped.</p>

<p>Indeed, it was his Navy service that had greatly boosted his career. During the war, he had met a radio operator in the Marshall Islands named Bernie Schwartz who had told him, “I’m going to be a movie star.” Storch, already a seasoned comic on the resort circuit, had tried to talk him out of it, warning him that the business could be tough.</p>

<p>They met again after the war, and Schwartz, who by now had changed his name to Tony Curtis, remembered the funny guy from the islands. Storch went on to appear in eight of Curtis’ movies, including “Captain Newman,” “Who Was That Lady?” and “The Great Race.”</p>

<p>Laurence Samuel Storch was born in New York City where, he recalled proudly, he went on to become class clown at DeWitt Clinton High School and “was invited not to come back.”</p>

<p>He practiced his comedy in Harlem theaters for $2 a night before graduating to the famed training ground for comedians of his era, the Catskills.</p>

<p>His first big break came on TV in the early 1950s with “The Cavalcade of Stars,” with Jackie Gleason. That led to “The Larry Storch Show,” a 1953 summer series. Regular movie and TV work followed.</p>

<p>Storch was married to Norma Greve from 1961 until her death in 2003.</p>

<p>___</p>

<p>The late Associated Press writer Bob Thomas contributed to this report.</p>

									</div>
											<div class="article-copyright">Copyright AP - Associated Press</div>
				<div class="article-footer">
			<div class="article-tags">
	<h4 class="article-tags__heading">This article tagged under:</h4>
	<a class="article-tags__tag" href="https://www.nbcwashington.com/tag/larry-storch/">larry storch</a></div>
			<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcwashington.com%2Fentertainment%2Fentertainment-news%2Flarry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99%2F3096337%2F&#038;Larry%20Storch%2C%20Zany%20Cpl.%20Agarn%20on%20TV%27s%20%E2%80%98F%20Troop%2C%27%20Dies%20at%2099?_osource=db_npd_nbc_wrc_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Larry%20Storch%2C%20Zany%20Cpl.%20Agarn%20on%20TV%27s%20%E2%80%98F%20Troop%2C%27%20Dies%20at%2099&#038;url=https%3A%2F%2Fwww.nbcwashington.com%2Fentertainment%2Fentertainment-news%2Flarry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99%2F3096337%2F?_osource=db_npd_nbc_wrc_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Larry%20Storch%2C%20Zany%20Cpl.%20Agarn%20on%20TV%27s%20%E2%80%98F%20Troop%2C%27%20Dies%20at%2099%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcwashington.com%2Fentertainment%2Fentertainment-news%2Flarry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99%2F3096337%2F?_osource=db_npd_nbc_wrc_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
			<a href="#" data-service="comments">
			<span class="icon icon-comment-alt"></span>
		</a>
	</div>
		</div>
					<div id="div-gpt-ad-mobilemultibox_belowarticle" class="widget_ad_layers_ad_widget gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_belowarticle', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script>	<div id="taboola-below-article-thumbnails"></div>

	<script type="text/javascript">
		if (document.cookie.indexOf("scroll0=") < 0) {
			window._taboola = window._taboola || [];
			_taboola.push({
				article: 'auto',
				url: ''
			});
						_taboola.push({
				mode: 'thumbnails-a',
				container: 'taboola-below-article-thumbnails',
				placement: 'Below Article Thumbnails',
				target_type: 'mix'
			});
						_taboola.push({
				flush: true
			});
		};
	</script>
		<div id="mobile-native-below-article"></div>
	<script type="text/javascript">
		var isMobile = window.matchMedia('screen and (max-width: 767px)').matches;
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0 && isMobile) {
			window._taboola = window._taboola || [];
			_taboola.push({
				mode: 'thumbs-feed-03-mobile',
				container: 'mobile-native-below-article',
				placement: 'Below Article Thumbnails - Fallback',
				target_type: 'text'
			});
		};
	</script>
					</div>
		</div>
		<div class="section-content--secondary">
			<aside class="sidebar article-sidebar">
						<section id="nbc_most_popular-2" class="widget widget_nbc_most_popular">		<div class="most-popular__header">
			<h3 class="widget-title">Trending Stories</h3>
			<div class="sponsored-ad-container">
				<div id="div-gpt-ad-logo_trending" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_trending', format: 'logo', targeting: {"slot":"logo","pos":"logo"} });
			</script>			</div>
		</div>
		<ul class="most-popular__posts-list">
							<li class="most-popular__post">
					<div class="post__image__wrap">
												<a
							data-lpos="most-popular"
							data-lid="Charles County Surpasses Prince George&#039;s as Wealthiest Black County in US: Post"
							href="https://www.nbcwashington.com/news/local/prince-georges-county/charles-county-surpasses-prince-georges-as-wealthiest-black-county-in-us-post/3095774/"
						>
							<img
								class="post__image"
								src="https://media.nbcwashington.com/2022/07/Prince-Georges-Falls-to-Second-Wealthiest-Black-County.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
								alt="Charles County Surpasses Prince George&#039;s as Wealthiest Black County in US: Post"
								loading="lazy"
							/>
						</a>
											</div>

					<div class="post__content">
													<h4 class="post__category">
								<a
									data-lpos="most-popular"
									data-lid="Prince George&#039;s Co."
									href="https://www.nbcwashington.com/tag/prince-georges-co/"
								>
									Prince George&#039;s Co.								</a>
							</h4>
												<div class="post__title">
							<a
								data-lpos="most-popular"
								data-lid="Charles County Surpasses Prince George&#039;s as Wealthiest Black County in US: Post"
								href="https://www.nbcwashington.com/news/local/prince-georges-county/charles-county-surpasses-prince-georges-as-wealthiest-black-county-in-us-post/3095774/"
							>
								Charles County Surpasses Prince George&#039;s as Wealthiest Black County in US: Post							</a>
						</div>
											</div>
				</li>
							<li class="most-popular__post">
					<div class="post__image__wrap">
												<a
							data-lpos="most-popular"
							data-lid="911 Operator Charged in Woman&#039;s Death After Failing to Send Ambulance"
							href="https://www.nbcwashington.com/news/national-international/pennsylvania-dispatcher-who-didnt-send-ambulance-charged-in-2020-death/3096023/"
						>
							<img
								class="post__image"
								src="https://media.nbcwashington.com/2022/07/DISPATCHER-CHARGED.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
								alt="911 Operator Charged in Woman&#039;s Death After Failing to Send Ambulance"
								loading="lazy"
							/>
						</a>
											</div>

					<div class="post__content">
													<h4 class="post__category">
								<a
									data-lpos="most-popular"
									data-lid="911 operator"
									href="https://www.nbcwashington.com/tag/911-operator/"
								>
									911 operator								</a>
							</h4>
												<div class="post__title">
							<a
								data-lpos="most-popular"
								data-lid="911 Operator Charged in Woman&#039;s Death After Failing to Send Ambulance"
								href="https://www.nbcwashington.com/news/national-international/pennsylvania-dispatcher-who-didnt-send-ambulance-charged-in-2020-death/3096023/"
							>
								911 Operator Charged in Woman&#039;s Death After Failing to Send Ambulance							</a>
						</div>
											</div>
				</li>
							<li class="most-popular__post">
					<div class="post__image__wrap">
												<a
							data-lpos="most-popular"
							data-lid="Young Father Killed in Beltsville"
							href="https://www.nbcwashington.com/news/local/young-father-killed-in-beltsville/3095594/"
						>
							<img
								class="post__image"
								src="https://media.nbcwashington.com/2022/07/dorsey.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
								alt="Young Father Killed in Beltsville"
								loading="lazy"
							/>
						</a>
											</div>

					<div class="post__content">
													<h4 class="post__category">
								<a
									data-lpos="most-popular"
									data-lid="shooting"
									href="https://www.nbcwashington.com/tag/shooting/"
								>
									shooting								</a>
							</h4>
												<div class="post__title">
							<a
								data-lpos="most-popular"
								data-lid="Young Father Killed in Beltsville"
								href="https://www.nbcwashington.com/news/local/young-father-killed-in-beltsville/3095594/"
							>
								Young Father Killed in Beltsville							</a>
						</div>
											</div>
				</li>
							<li class="most-popular__post">
					<div class="post__image__wrap">
												<a
							data-lpos="most-popular"
							data-lid="Man Killed by Police in McLean Home After 2 Calls for Person in Crisis: Fairfax Co. Chief"
							href="https://www.nbcwashington.com/news/local/northern-virginia/man-killed-in-officer-involved-shooting-in-mclean-police/3095808/"
						>
							<img
								class="post__image"
								src="https://media.nbcwashington.com/2022/07/McLean-police-involved-shooting-scene.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
								alt="Man Killed by Police in McLean Home After 2 Calls for Person in Crisis: Fairfax Co. Chief"
								loading="lazy"
							/>
						</a>
											</div>

					<div class="post__content">
													<h4 class="post__category">
								<a
									data-lpos="most-popular"
									data-lid="officer-involved shooting"
									href="https://www.nbcwashington.com/tag/officer-involved-shooting/"
								>
									officer-involved shooting								</a>
							</h4>
												<div class="post__title">
							<a
								data-lpos="most-popular"
								data-lid="Man Killed by Police in McLean Home After 2 Calls for Person in Crisis: Fairfax Co. Chief"
								href="https://www.nbcwashington.com/news/local/northern-virginia/man-killed-in-officer-involved-shooting-in-mclean-police/3095808/"
							>
								Man Killed by Police in McLean Home After 2 Calls for Person in Crisis: Fairfax Co. Chief							</a>
						</div>
											</div>
				</li>
							<li class="most-popular__post">
					<div class="post__image__wrap">
												<a
							data-lpos="most-popular"
							data-lid="Drive-by Shooting Sends People Running for Cover in Arlington"
							href="https://www.nbcwashington.com/news/local/northern-virginia/drive-by-shooting-sends-people-running-for-cover-in-arlington/3095854/"
						>
							<img
								class="post__image"
								src="https://media.nbcwashington.com/2022/07/Chaos-Erupts-at-Store-After-Driveby-Shooting.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
								alt="Drive-by Shooting Sends People Running for Cover in Arlington"
								loading="lazy"
							/>
						</a>
											</div>

					<div class="post__content">
													<h4 class="post__category">
								<a
									data-lpos="most-popular"
									data-lid="drive-by shooting"
									href="https://www.nbcwashington.com/tag/drive-by-shooting/"
								>
									drive-by shooting								</a>
							</h4>
												<div class="post__title">
							<a
								data-lpos="most-popular"
								data-lid="Drive-by Shooting Sends People Running for Cover in Arlington"
								href="https://www.nbcwashington.com/news/local/northern-virginia/drive-by-shooting-sends-people-running-for-cover-in-arlington/3095854/"
							>
								Drive-by Shooting Sends People Running for Cover in Arlington							</a>
						</div>
											</div>
				</li>
										<li class="most-popular__post taboola__post">
					<div id="taboola-right-rail-thumbnails---fallback"></div>
				</li>
				<script>
					try {
						window._taboola = window._taboola || [];
						_taboola.push({
							listenTo: 'nocontent',
							placement: 'Right Rail Thumbnails - Fallback',
							handle: function() {
								document.querySelector('.most-popular__post:nth-of-type(5)').remove();
							}
						});
						_taboola.push({
							mode: 'thumbnails-a-right-rail',
							container: 'taboola-right-rail-thumbnails---fallback',
							placement: 'Right Rail Thumbnails - Fallback',
							target_type: 'mix',
							flush: true,
						});
					} catch (e) {
						console.error(e);
					}
				</script>
					</ul>
		</section><section id="ad_layers_ad_widget-2" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-topbox_224" class=" gpt-topbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbox_224', format: 'topbox', targeting: {"slot":"topbox","pos":"topbox"} });
			</script></section><section id="nbc_weather_widget-3" class="widget widget_nbc_weather_widget">		<div class="nbc-weather-widget">
			<div class="nbc_owned_television_stations_weather_iframe">
	<h3>Weather Forecast</h3><div data-react-component="IframeLocation" data-market-name="Washington, DC"></div>
	<a class="weather-module__conditions" href="https://www.nbcwashington.com/weather/">
		<div data-react-component="IframeConditions" data-location="20001"></div>
	</a>
		<div class="widget_sponsor">
		<div id="div-gpt-ad-logo_weather_495" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_weather_495', format: 'logo', targeting: {"module":"weather","slot":"logo","pos":"logo"} });
			</script>	</div>
</div>
		</div>
		</section><section id="ad_layers_ad_widget-9" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilemultibox_163" class=" gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_163', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script></section><section id="nbc_civic_science-2" class="widget widget_nbc_civic_science"><div id="civsci-351285633" class="module-civicScience" data-tgtid="70695a6b-e0bc-3854-d920-55a071a90268"></div></section><section id="ad_layers_ad_widget-6" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-bottombox_944" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_944', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script></section><section id="ad_layers_ad_widget-12" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-interstitial_921" class=" gpt-interstitial" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'interstitial_921', format: 'interstitial', targeting: {"slot":"interstitial","pos":"interstitial"} });
			</script></section><section id="ad_layers_ad_widget-13" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilebackstage_920" class=" gpt-mobilebackstage" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilebackstage_920', format: 'mobilebackstage', targeting: {"slot":"mobilebackstage","pos":"mobilebackstage"} });
			</script></section>			</aside>
		</div>
	</div>
</article>

			</main>
		</div>

		
	</div><!-- #content -->
	
<footer role="contentinfo" class="site-footer">
	<div class="site-footer__wrapper">
		<div class="site-footer__identity">
							<a href="https://www.nbcwashington.com/" class="site-footer__logo">
					<img
						src="https://media.nbcwashington.com/2019/09/DC_On_Light@3x.png?fit=558%2C120&#038;quality=85&#038;strip=all"
						alt="NBC4 Washington"
						loading="lazy"
					/>
				</a>
			
			
			<ul class="site-footer__social-list">
				
									<li class="site-footer__social-list-item facebook">
						<a href="http://www.facebook.com/nbcwashington" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Facebook</span>
							<span class="icon icon-facebook-f"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item twitter">
						<a href="https://twitter.com/nbcwashington" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Twitter</span>
							<span class="icon icon-twitter"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item instagram">
						<a href="https://instagram.com/nbcwashington" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Instagram</span>
							<span class="icon icon-instagram"></span>
						</a>
					</li>
							</ul>
		</div>

		<ul id="menu-footer" class="footer-menu site-footer__menu-primary"><li id="menu-item-2168443" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2168443"><a href="/investigations/submit-tip/">Submit Tips for Investigations</a></li>
<li id="menu-item-2168444" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2168444"><a href="/newsletters/">Newsletters</a></li>
<li id="menu-item-2168446" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2168446"><a href="/contact-us/">Connect With Us</a></li>
</ul><ul id="menu-secondary-footer" class="footer-menu-secondary site-footer__menu-secondary"><li id="menu-item-1960845" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1960845"><a href="https://www.nbcwashington.com/send-feedback/">Send Feedback</a></li>
<li id="menu-item-1960843" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1960843"><a href="https://www.nbcwashington.com/wrc-employment-information/">WRC EMPLOYMENT INFORMATION</a></li>
<li id="menu-item-2457801" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2457801"><a href="https://www.nbcwashington.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-1960844" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1960844"><a href="https://www.nbcwashington.com/terms-of-service/">TERMS OF SERVICE</a></li>
<li id="menu-item-1960824" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1960824"><a target="_blank" rel="noopener noreferrer" href="https://www.nbcuniversal.com/privacy/?brandA=Owned_Stations&#038;intake=NBC4_Washington/">Privacy Policy</a></li>
<li id="menu-item-1960819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1960819"><a href="https://publicfiles.fcc.gov/tv-profile/WRC-TV">WRC Public Inspection File</a></li>
<li id="menu-item-2153418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2153418"><a href="https://www.nbcuniversal.com/privacy/notrtoo?brandA=Owned_Stations&#038;intake=NBC4_Washington/">Do Not Sell My Personal Information</a></li>
<li id="menu-item-1960829" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1960829"><a href="https://together.nbcuni.com/advertise/?utm_source=nbcwashington&#038;utm_medium=referral&#038;utm_campaign=property_ad_pages">Advertise with us</a></li>
<li id="menu-item-2368191" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2368191"><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NBC4_Washington">CA Notice</a></li>
<li id="menu-item-1960827" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1960827"><a target="_blank" rel="noopener noreferrer" href="https://www.nbcuniversal.com/privacy/cookies#accordionheader2">Ad Choices</a></li>
</ul>
				<div class="site-footer__corporate">
			
			<span class="site-footer__corporate-copyright">
				Copyright © 2022 NBCUniversal Media, LLC. All rights reserved			</span>
		</div>
	</div><!-- wrapper -->
</footer><!-- #colophon -->
</div><!-- #page -->

	<script type="text/javascript">
	(function() {
		var _sf_async_config      = window._sf_async_config = window._sf_async_config || {};
		_sf_async_config.domain   = "nbcwashington.com";
		_sf_async_config.uid      = 15527;
		_sf_async_config.sections = "entertainment, entertainment-news";
		_sf_async_config.authors  = "Lynn Elber";
		_sf_async_config.title    = "Larry Storch, Zany Cpl. Agarn on TV's \u2018F Troop,' Dies at 99";
		_sf_async_config.path     = "nbcwashington.com\/entertainment\/entertainment-news\/larry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99\/3096337\/";
		
		var e = document.createElement('script');
		var n = document.getElementsByTagName('script')[0];
		e.type = 'text/javascript';
		e.async = true;
		e.src = '//static.chartbeat.com/js/chartbeat.js';
		n.parentNode.insertBefore(e, n);
	})();
	</script>
			<!-- Begin comScore Tag -->
		<script>
			(function() {
				var usPrivacyCookie = new RegExp("usprivacy=([^;]+)").exec(document.cookie),
					usPrivacy = null !== usPrivacyCookie ? unescape(usPrivacyCookie[1]) : undefined,
					csUCFR = '1YYN' === usPrivacy ? '0': '',
					s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];

				window._comscore = window._comscore || [];

				window._comscore.push({
					c1: "2",
					c2: "6035083",
					cs_ucfr: csUCFR,
				});

				s.async = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
				<script type="text/javascript">
		(function() {
			var loaderUrl, scriptType;
			window._taboola = window._taboola || [];
			window._newsroom = window._newsroom || [];
			const taboola_config = {};

			taboola_config[decodeURIComponent( 'article' )] = decodeURIComponent( '3096337' );
			taboola_config['url'] = document.URL;
			taboola_config['tracking'] = '_osource=taboola-recirc';
			_taboola.push(taboola_config);

						scriptType = 'tb_loader_script';
			loaderUrl = 'https://cdn.taboola.com/libtrc/nbcots-network/loader.js';
			
			!function (e, f, u, i) {
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			loaderUrl,
			scriptType);

			!function (e, f, u) {
				e.async = 1;
				e.src = u;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			"\/\/c2.taboola.com\/nr\/nbcots-wrc\/newsroom.js");
		}());
		</script>
				<div class="facebook-comments">
			<button class="facebook-comments__close"><span class="icon icon-chevron-left"></span> Back to Article</button>
			<div class="fb-comments" data-href="https://www.nbcwashington.com/entertainment/entertainment-news/larry-storch-zany-cpl-agarn-on-tvs-f-troop-dies-at-99/3096337/" data-width="100%"></div>
		</div>
		<div class="flyout-nav" data-component="flyoutNav">
	<button class="flyout-nav__close"><span class="icon icon-times"></span> <span class="screen-reader-text">Close Menu</span></button>
	<div class="flyout-nav__logo">
		<a href="https://www.nbcwashington.com/">
					<img
						src="https://media.nbcwashington.com/2019/09/DC_On_Light@3x.png?fit=558%2C120&#038;quality=85&#038;strip=all"
						alt="NBC4 Washington"
					/>
		</a>
	</div>
	<div class="flyout-nav__search">
<form class="search-form" role="search" method="get" action="https://www.nbcwashington.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
</div>
	<div class="flyout-nav__menu">
		<div class="flyout-nav__menu--upper">
							<a data-lid="Coronavirus Pandemic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/coronavirus/">
					Coronavirus Pandemic				</a>
							<a data-lid="Local" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/">
					Local				</a>
							<a data-lid="Northern Virginia" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/northern-virginia/">
					Northern Virginia				</a>
							<a data-lid="Prince George&#039;s County" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/prince-georges-county/">
					Prince George&#039;s County				</a>
							<a data-lid="Weather" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/weather/">
					Weather				</a>
							<a data-lid="Changing Climate" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/changing-climate/">
					Changing Climate				</a>
							<a data-lid="Videos" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="https://www.nbcwashington.com/videos/">
					Videos				</a>
							<a data-lid="Investigations" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/investigations/">
					Investigations				</a>
							<a data-lid="NBC4 Responds" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/nbc4-responds/">
					NBC4 Responds				</a>
							<a data-lid="4 Your Home" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="https://www.nbcwashington.com/tag/4-your-home/">
					4 Your Home				</a>
							<a data-lid="U.S. &amp; World" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/national-international/">
					U.S. &amp; World				</a>
							<a data-lid="Politics" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/politics/">
					Politics				</a>
							<a data-lid="Health" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/health/">
					Health				</a>
							<a data-lid="Changing Minds" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcwashington.com/news/local/changing-minds/">
					Changing Minds				</a>
							<a data-lid="LX News" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/lxnews/">
					LX News				</a>
							<a data-lid="NBC Sports" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/sports/nbcsports/">
					NBC Sports				</a>
							<a data-lid="The Scene" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/entertainment/the-scene/">
					The Scene				</a>
							<a data-lid="Community" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/community/">
					Community				</a>
							<a data-lid="Vote: Polls &amp; Trivia" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="http://nbcwashington.com/vote">
					Vote: Polls &amp; Trivia				</a>
					</div>
		<div class="flyout-nav__menu--lower">
							<a data-lid="Our Apps" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/products/">
					Our Apps				</a>
							<a data-lid="Submit Photos and Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/ugc/">
					Submit Photos and Video				</a>
							<a data-lid="Submit a Consumer Complaint" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/consumer-form/">
					Submit a Consumer Complaint				</a>
							<a data-lid="Promotions" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/promotions/">
					Promotions				</a>
							<a data-lid="Newsletters" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/newsletters/">
					Newsletters				</a>
							<a data-lid="On-Air Mentions" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/here-are-the-links-you-heard-about-on-news4/54869/">
					On-Air Mentions				</a>
							<a data-lid="Cozi TV" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://cozitv.com/">
					Cozi TV				</a>
					</div>
	</div>
	<div class="flyout-nav__social">
		<h4 class="flyout-nav__social-heading">Follow Us</h4>
		<ul class="flyout-nav__social-list">
			
							<li class="site-footer__social-list-item facebook" rel="noopener noreferrer">
					<a href="http://www.facebook.com/nbcwashington" target="_blank">
						<span class="screen-reader-text">Facebook</span>
						<span class="icon icon-facebook-f"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item twitter" rel="noopener noreferrer">
					<a href="https://twitter.com/nbcwashington" target="_blank">
						<span class="screen-reader-text">Twitter</span>
						<span class="icon icon-twitter"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item instagram" rel="noopener noreferrer">
					<a href="https://instagram.com/nbcwashington" target="_blank">
						<span class="screen-reader-text">Instagram</span>
						<span class="icon icon-instagram"></span>
					</a>
				</li>
					</ul>
	</div>
</div>
<a class="flyout-contact-button" data-lid="Contact Us" data-lpos="hamburger-menu"
			href="/contact-us"
	>
	Contact Us</a>
<link rel='stylesheet' id='all-css-0' href='https://www.nbcwashington.com/_static/??-eJydzDsOwjAQRdENEX/if4GoadjDeDwRlhIbxQ4RuycULADqd9/h+2PAWjqVzvudFmq8RBxah55r4TjnzxK3PCeOrfGp1k4roxAMUgSdYgxEYC2NbMmFHc2J/2rOr7r1GzxZQEDtwHoFiErG0Xj5N7sTHNl6PT6NCQ3Ji8mm5I2WTkxJua98Wc7SGqeElla/AcHRX10=' type='text/css' media='all' />
<script src='https://www.nbcwashington.com/wp-content/mu-plugins/jetpack-9.4/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script defer src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0' id='moat-js'></script>
<script src='https://www.nbcwashington.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://www.nbcwashington.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.nbcwashington.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.nbcwashington.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.nbcwashington.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.nbcwashington.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.nbcwashington.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script src='https://www.nbcwashington.com/wp-includes/js/dist/i18n.min.js?ver=4ab02c8fd541b8cfb8952fe260d21f16' id='wp-i18n-js'></script>
<script src='https://www.nbcwashington.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.21' id='lodash-js'></script>
<script id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script src='https://www.nbcwashington.com/wp-includes/js/dist/url.min.js?ver=d80b474ffb72c3b6933165cc1b3419f6' id='wp-url-js'></script>
<script src='https://www.nbcwashington.com/wp-includes/js/dist/hooks.min.js?ver=63769290dead574c40a54748f22ada71' id='wp-hooks-js'></script>
<script id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://www.nbcwashington.com/wp-includes/js/dist/api-fetch.min.js?ver=0bb73d10eeea78a4d642cdd686ca7f59' id='wp-api-fetch-js'></script>
<script id='wp-api-fetch-js-after'>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</script>
<script src='https://www.nbcwashington.com/wp-content/themes/nbc-station/client/build/js/common.c77b83a827c5712ec289.bundle.min.js?ver=1.0.2' id='nbc-common-js-js'></script>
<script async src='https://www.nbcwashington.com/wp-content/themes/nbc-station/client/build/js/global.bc0c7c16b3411a8d9e54.bundle.min.js?ver=1.0.2' id='nbc-global-js'></script>
<script async src='https://www.nbcwashington.com/wp-content/themes/nbc-station/client/build/js/article.439d84c17cd92b9477e6.bundle.min.js?ver=1.0.2' id='nbc-article-js-js'></script>
<script defer src='https://assets.adobedtm.com/a2ef59fba8e9/3ba8c6b033ff/launch-6a742ce4ddf5.min.js?ver=1.0.2' id='adobe-launch-js'></script>
<script defer src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=1.0.0' id='nbc-sailthru-js'></script>
<script id='nbc-sailthru-js-after'>
if ("undefined" !== typeof Sailthru) { Sailthru.init({"customerId":"757cc89c051f4552fa5708e6f3b93a01"}); }
</script>
<script defer src='https://native.sharethrough.com/assets/sfp.js?ver=5.5.9' id='sharethrough-js'></script>
<script async src='https://www.nbcwashington.com/wp-content/themes/nbc-station/client/build/js/flyoutNav.d5c7059c7d75fb8f3d73.bundle.min.js?ver=1.0.2' id='nbc-flyout-nav-js'></script>
<script src='https://www.nbcwashington.com/wp-content/themes/nbc-station/client/build/js/articleContent.3f5fe9de74890486d99b.bundle.min.js?ver=1.0.2' id='nbc-article-content-js'></script>
<script async src='https://www.nbcwashington.com/wp-content/themes/nbc-station/client/build/js/weatherConditions.6094cd490c241c388199.bundle.min.js?ver=1.0.2' id='nbc-weather-conditions-js'></script>
<script defer src='https://js-sec.indexww.com/ht/p/185796-256714881512110.js?ver=1.0.2' id='nbc-index-exchange-js'></script>
<script src='https://www.nbcwashington.com/wp-includes/js/wp-embed.min.js?ver=5.5.9' id='wp-embed-js'></script>
<script src='https://www.nbcwashington.com/wp-content/themes/nbc-station/client/build/js/civicScience.3435258b523b047b5fa7.bundle.min.js?ver=1.0.2' id='civic-science-js'></script>
<script src='https://stats.wp.com/e-202227.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4.1',blog:'165596213',post:'3096337',tz:'-4',srv:'www.nbcwashington.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '165596213', '3096337' ]);
</script>

</body>
</html>
